#3 04-02-2007, 08:05 PM richone52 Member Join Date: Apr 2007 Location: San Jose Posts: 46 Quote: Originally I will call tomorrow about the camera.

I am bringin it back in on Weds... I checked my vehicle settings it it says "all systems OK". Additionally, on two occasions, when I put the X5 in reverse, the camera blanked out on me, instead putting a rainbow of vertical lines on the screen (like a television that Broken vent controls - 2 out of the 4 front vents were broken and would not adjust the direction of the air. 5.

XZLR8 View Public Profile Find all threads started by XZLR8 Find all posts by XZLR8 View My Garage Add XZLR8 to Your Ignore List #5 06-04-2007, 02:18 AM onesixeight Thanks Appreciate 0 Quote bebeqq1231 View Public Profile Find More Posts by bebeqq1231 04-07-2014, 02:41 PM #8 Roychimac Second Lieutenant 58Rep 236Posts Drives: 15 YMB F80 Join Date: Nov The window was very much tightly closed. Can anyone help?

All rights reserved. The hitch for the E53 X5 was expensive, yes (about $900 for hitch, wiring harness, and labor). It happened to me once but it came back up after few minutes. As I suspected and was concerned with them tearing the car apart they damaged the inside of my rear door and the plastic is all dented.

I was thinking they would update my software because of various problems I'm having like showing the wrong station, delay or lock ups, lost presets,... It is a lease so I always go to the dealer since it is all covered under warranty so I don't know anyone that could take a look. When I came back and put the car in reverse this is all I get (see picture). As a point of history, when I picked up the car after learning all about it I got a warning of Camera failure and was to bring it back the next